summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorJudy Hsiao <judyhsiao@google.com>2020-02-04 12:30:01 +0800
committerCommit Bot <commit-bot@chromium.org>2020-03-20 15:26:02 +0000
commitd5c1e968c9454af0da573242a8dc3dcf63dd1820 (patch)
treec59a4b27ffdd968725a735c91c1233ee4d5afa9e /devices/Cargo.toml
parente5113047d5440bf09b2596f8a43f12d8e2b0061d (diff)
downloadcrosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar.gz
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar.bz2
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar.lz
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar.xz
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.tar.zst
crosvm-d5c1e968c9454af0da573242a8dc3dcf63dd1820.zip
audio: Create AC97 device with --ac97 option
1. Replace --cras-audio, --cras-capture, null-audio options by --ac97
option to create audio devices.
2. "--ac97 backend=BACKEND\
[capture=true,capture_effect=EFFECT]" is comma
separated key=value pairs for setting up Ac97 devices.
It can be given more than once to create multiple devices. Possible
key values are:
backend=(null, cras) - Where to route the audio device.
`null` for /dev/null, and  cras for CRAS server.
capture=true - Enable audio capture.
capture_effects - | separated effects to be enabled
for recording. The only supported effect value now is EchoCancellation
or aec.

BUG=b:140866281
TEST=1.crosvm run -r ./vm_rootfs.img -c 4 -m 1024 -s /run --cid 5 --host_ip\
100.115.92.25 --netmask 255.255.255.252 --ac97\
backend=cras,capture=true,capture_effect=aec\
--mac d2:47:f7:c5:9e:53 ./vm_kernel
2. Record with the vm by:
arecord -D hw:0,0 -d5 -fS16_LE -c2 -r48000 /tmp/test.mp3
3. Verify that AEC is enabled within the recording stream by
cras_test_cleint.

Cq-Depend: chromium:2053654
Cq-Depend: chromium:2095644
Cq-Depend: chromium:2038221
Change-Id: Ia9e0e7cda1671a4842ec77a354efaa4a2dc745eb
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/crosvm/+/2038413
Tested-by: Judy Hsiao <judyhsiao@chromium.org>
Commit-Queue: Judy Hsiao <judyhsiao@chromium.org>
Reviewed-by: Chih-Yang Hsia <paulhsia@chromium.org>
Auto-Submit: Judy Hsiao <judyhsiao@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index 83aa406..629f29b 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -25,6 +25,7 @@ io_jail = { path = "../io_jail" }
 kvm = { path = "../kvm" }
 kvm_sys = { path = "../kvm_sys" }
 libc = "*"
+libcras = "*"
 linux_input_sys = { path = "../linux_input_sys" }
 msg_on_socket_derive = { path = "../msg_socket/msg_on_socket_derive" }
 msg_socket = { path = "../msg_socket" }