summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-08-15 10:46:32 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-12-11 19:33:56 -0800
commitaa5756669a8331420b84a22e29ddbfc13b791da5 (patch)
tree3a2767b6ecc2779ca1e9f64ff7c60d8ae3bf8fdf /devices/Cargo.toml
parent42c409c4d7c661ead9794c54811ce5fadf0ae8e7 (diff)
downloadcrosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar.gz
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar.bz2
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar.lz
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar.xz
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.tar.zst
crosvm-aa5756669a8331420b84a22e29ddbfc13b791da5.zip
devices: allow virtio-wayland to use virtgpu resources
This change uses the resource bridge between virtio-gpu and virtio-cpu
to send resources over the host wayland connection that originated from
the virtio-gpu device. This will help support gpu accelerated wayland
surfaces.

BUG=chromium:875998
TEST=wayland-simple-egl

Change-Id: I3340ecef438779be5cb3643b2de8bb8c33097d75
Reviewed-on: https://chromium-review.googlesource.com/1182793
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index 8ed200d..3556bb6 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -15,8 +15,9 @@ gpu_display = { path = "../gpu_display", optional = true }
 gpu_renderer = { path = "../gpu_renderer", optional = true }
 kvm = { path = "../kvm" }
 libc = "*"
-msg_socket = { path = "../msg_socket" }
 io_jail = { path = "../io_jail" }
+msg_on_socket_derive = { path = "../msg_socket/msg_on_socket_derive" }
+msg_socket = { path = "../msg_socket" }
 net_sys = { path = "../net_sys" }
 net_util = { path = "../net_util" }
 p9 = { path = "../p9" }