summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorChirantan Ekbote <chirantan@chromium.org>2019-07-17 10:48:02 +0900
committerCommit Bot <commit-bot@chromium.org>2019-10-16 06:53:47 +0000
commit99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5 (patch)
tree6a8dc1545bcb599a08bec5b8a4178af7be2b0787 /devices/Cargo.toml
parentb5964164c4d6187971495ccf82fd64a1d5bde232 (diff)
downloadcrosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar.gz
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar.bz2
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar.lz
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar.xz
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.tar.zst
crosvm-99e6a6fb1fc5c46fd19737ed3ce04ce042f29fc5.zip
devices: fs: Add fuse constants and struct definitions
Add the constants and struct definitions from the kernel fuse interface.
These bindings are manually generated from `include/uapi/linux/fuse.h`
in the kernel repo.

BUG=b:136128319
TEST=none;  these aren't used anywhere yet

Change-Id: I03d11bc55eca6b8269f1e63a1187ef458ee16f28
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/crosvm/+/1705655
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Commit-Queue: Chirantan Ekbote <chirantan@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index 2ddfcd0..ab240c3 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -14,6 +14,7 @@ x = ["gpu_display/x"]
 [dependencies]
 audio_streams = "*"
 bit_field = { path = "../bit_field" }
+bitflags = "1"
 data_model = { path = "../data_model" }
 disk = { path = "../disk" }
 enumn = { path = "../enumn" }