summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-03-12 20:49:35 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-15 02:06:04 -0700
commit1b7f3ed23505b83343b376c8d8777366457402d0 (patch)
tree26d1cb69582c1b645a1771cc0a64b96c9649871f /devices/Cargo.toml
parent3df3552e4d62d60aac3bc33a4ee9468e7514202f (diff)
downloadcrosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar.gz
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar.bz2
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar.lz
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar.xz
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.tar.zst
crosvm-1b7f3ed23505b83343b376c8d8777366457402d0.zip
edition: Update devices crate to 2018 edition
Separated out of CL:1513058 to make it possible to land parts
individually while the affected crate has no other significant CLs
pending. This avoids repeatedly introducing non-textual conflicts with
new code that adds `use` statements.

TEST=cargo check
TEST=cargo check --all-features
TEST=cargo check --target aarch64-unknown-linux-gnu

Change-Id: I964a198b54dfa7b98fa2f49a404fda3d09c0f44f
Reviewed-on: https://chromium-review.googlesource.com/1519693
Commit-Ready: David Tolnay <dtolnay@chromium.org>
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: David Tolnay <dtolnay@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index cd554c9..62b570e 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -2,6 +2,7 @@
 name = "devices"
 version = "0.1.0"
 authors = ["The Chromium OS Authors"]
+edition = "2018"
 
 [features]
 gpu = ["gpu_buffer", "gpu_display", "gpu_renderer"]