summary refs log tree commit diff
path: root/devices/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-04-05 11:56:44 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-12 14:49:56 -0700
commit1aca8b72694fcbefc4f31bf49f41e7491ad29db4 (patch)
treed72869d83287d9b3e384e0bfa15c969eb9fea0c1 /devices/Cargo.toml
parentfd67ec5ffc84d8726ebcb141ddb93e10a046ee72 (diff)
downloadcrosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar.gz
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar.bz2
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar.lz
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar.xz
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.tar.zst
crosvm-1aca8b72694fcbefc4f31bf49f41e7491ad29db4.zip
protos: Compile protos for trunks daemon
The TPM device will need these protos to communicate TPM commands to the
Trunks daemon and receive TPM responses.

BUG=chromium:911799
TEST=cargo check
TEST=cargo check --features tpm
TEST=FEATURES=test emerge-nami crosvm
TEST=FEATURES=test USE=crosvm-tpm emerge-nami crosvm
TEST=local kokoro
CQ-DEPEND=CL:1553610
CQ-DEPEND=CL:1553971

Change-Id: I1a67a7b4a3714236b20a790068ca19129446f71c
Reviewed-on: https://chromium-review.googlesource.com/1554982
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: David Tolnay <dtolnay@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'devices/Cargo.toml')
-rw-r--r--devices/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/devices/Cargo.toml b/devices/Cargo.toml
index c1ddad0..d916df8 100644
--- a/devices/Cargo.toml
+++ b/devices/Cargo.toml
@@ -6,7 +6,7 @@ authors = ["The Chromium OS Authors"]
 [features]
 gpu = ["gpu_buffer", "gpu_display", "gpu_renderer"]
 sandboxed-libusb = ["usb_util/sandboxed-libusb"]
-tpm = ["tpm2"]
+tpm = ["protos", "tpm2"]
 wl-dmabuf = []
 
 [dependencies]
@@ -26,6 +26,7 @@ msg_socket = { path = "../msg_socket" }
 net_sys = { path = "../net_sys" }
 net_util = { path = "../net_util" }
 p9 = { path = "../p9" }
+protos = { path = "../protos", optional = true }
 resources = { path = "../resources" }
 sync = { path = "../sync" }
 sys_util = { path = "../sys_util" }