summary refs log tree commit diff
path: root/cros_async/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2019-11-22 16:41:01 -0800
committerCommit Bot <commit-bot@chromium.org>2020-02-10 23:46:11 +0000
commit2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0 (patch)
tree21c6a9fefed7104a2bcdb9121c99111ffd3bf729 /cros_async/Cargo.toml
parent5c51e052820f6f6a2e65d1bd02ff8eee6a3241a2 (diff)
downloadcrosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar.gz
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar.bz2
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar.lz
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar.xz
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.tar.zst
crosvm-2cc138341dc601f3dfd3ebd4233a99b75ddb6bd0.zip
Add a cros_async crate.
This crate will house code using the new async/await features to be used
by other parts of crosvm.

Start the crate with a Future executor that runs tasks in a single
thread and allows futures that block on system file descriptors.

Change-Id: If77778ac056210dabbfc6e6e1e63df1c1b904a7f
Reviewed-on: https://chromium-review.googlesource.com/c/chromiumos/platform/crosvm/+/1955045
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Tested-by: Dylan Reid <dgreid@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Commit-Queue: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'cros_async/Cargo.toml')
-rw-r--r--cros_async/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/cros_async/Cargo.toml b/cros_async/Cargo.toml
new file mode 100644
index 0000000..4e62732
--- /dev/null
+++ b/cros_async/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "cros_async"
+version = "0.1.0"
+authors = ["The Chromium OS Authors"]
+edition = "2018"
+
+[dependencies]
+libc = "*"
+paste = "*"
+pin-utils = "0.1.0-alpha.4"
+sys_util = { path = "../sys_util" }
+syscall_defines = { path = "../syscall_defines" }
+
+[dependencies.futures]
+version = "*"
+default-features = false