summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-04-10 17:59:15 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-12 14:49:56 -0700
commitfd67ec5ffc84d8726ebcb141ddb93e10a046ee72 (patch)
tree1372d65c4a93f144a0ef39afc0e4ceaffd52f6a2 /Cargo.toml
parent0268e26e1ac9e09aa51d733482c5df139cd8d588 (diff)
downloadcrosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar.gz
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar.bz2
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar.lz
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar.xz
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.tar.zst
crosvm-fd67ec5ffc84d8726ebcb141ddb93e10a046ee72.zip
protos: Update to protobuf 2.3
This matches the version already used by crostini_client.

The newer protobuf version depends on the tempfile crate rather than
tempdir, the latter being now deprecated. So I replaced our immitation
tempdir crate with one that matches the API of tempfile instead. As a
reminder, we use this crate as a patch to avoid pulling in all of the
rand crate and its many dependencies.

TEST=cargo check --features plugin
CQ-DEPEND=CL:1553971

Change-Id: I28eed3ceadb1013f015400b4c582aaf8dc89eee1
Reviewed-on: https://chromium-review.googlesource.com/1562924
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 4a6edc5..27b128c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,7 +17,7 @@ exclude = [
     "sync",
     "sys_util",
     "syscall_defines",
-    "tempdir",
+    "tempfile",
 ]
 
 [features]
@@ -50,7 +50,7 @@ msg_socket = { path = "msg_socket" }
 net_util = { path = "net_util" }
 p9 = { path = "p9" }
 plugin_proto = { path = "plugin_proto", optional = true }
-protobuf = { version = "=1.4.3", optional = true }
+protobuf = { version = "2.3", optional = true }
 qcow = { path = "qcow" }
 rand_ish = { path = "rand_ish" }
 render_node_forward = { path = "render_node_forward", optional = true }
@@ -78,4 +78,4 @@ poll_token_derive = { path = "sys_util/poll_token_derive" }
 sync = { path = "sync" }
 sys_util = { path = "sys_util" }
 syscall_defines = { path = "syscall_defines" }
-tempdir = { path = "tempdir" }
+tempfile = { path = "tempfile" }