summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-10-15 15:40:09 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-10-16 02:57:36 -0700
commitf6b58e4cf28991c6d436c33c32e94a457dff0ebd (patch)
tree6ac40392c5480ee530dfadf5bfa1c6f0414778e1 /Cargo.toml
parent6b28917b83a99b5638fee0931114586da1ec9dba (diff)
downloadcrosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar.gz
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar.bz2
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar.lz
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar.xz
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.tar.zst
crosvm-f6b58e4cf28991c6d436c33c32e94a457dff0ebd.zip
enable integer overflow checks on release profile
This will harden crosvm against potential integer overflow leading to
unsafe behavior in unsafe blocks.

TEST=cargo test --release
BUG=None

Change-Id: Ie750906d04c6ef8cb9400b976827c2abeab2ab56
Reviewed-on: https://chromium-review.googlesource.com/1282064
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7d17364..c419574 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,6 +6,7 @@ authors = ["The Chromium OS Authors"]
 [profile.release]
 lto = true
 panic = 'abort'
+overflow-checks = true
 
 [workspace]
 members = ["9s"]