summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2017-08-26 18:05:48 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-09-02 00:18:25 -0700
commitefe957849b5d645b115f677701ad779d42ef7574 (patch)
tree4911944e10bcfb6581d5191b76ab4d051c8c6d53 /Cargo.toml
parente9321023861f8584df4237ecc4f3c8fbc01f90f3 (diff)
downloadcrosvm-efe957849b5d645b115f677701ad779d42ef7574.tar
crosvm-efe957849b5d645b115f677701ad779d42ef7574.tar.gz
crosvm-efe957849b5d645b115f677701ad779d42ef7574.tar.bz2
crosvm-efe957849b5d645b115f677701ad779d42ef7574.tar.lz
crosvm-efe957849b5d645b115f677701ad779d42ef7574.tar.xz
crosvm-efe957849b5d645b115f677701ad779d42ef7574.tar.zst
crosvm-efe957849b5d645b115f677701ad779d42ef7574.zip
crosvm: argument parsing without clap
This removes the clap dependency by replacing that functionality with a
custom written parser. Binary size is reduced by about 60% in optimized
and stripped mode.

TEST=cargo run -- run -h
BUG=None

Change-Id: I2eaf6fcff121ab16613c444693d95fdf3ad04da3
Reviewed-on: https://chromium-review.googlesource.com/636011
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 0 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c0b64ab..57e4f06 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -21,9 +21,5 @@ vhost = { path = "vhost" }
 virtio_sys = { path = "virtio_sys" }
 data_model = { path = "data_model" }
 
-[dependencies.clap]
-version = "*"
-default-features = false
-
 [target.'cfg(target_arch = "x86_64")'.dependencies]
 x86_64 = { path = "x86_64" }