summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2020-04-10 13:19:04 +0000
committerAlyssa Ross <hi@alyssa.is>2020-06-15 09:37:29 +0000
commiteb90518961ca5f00bd832429be840600ce305fb4 (patch)
tree8415abc6314ac439b47d90305194cc88eca76146 /Cargo.toml
parentaa9ee49fdf908aef32d4363704099a0584834d4c (diff)
downloadcrosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar.gz
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar.bz2
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar.lz
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar.xz
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.tar.zst
crosvm-eb90518961ca5f00bd832429be840600ce305fb4.zip
three parts
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index baf401b..2615178 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,20 +12,19 @@ name = "crosvm"
 path = "src/main.rs"
 
 [[bin]]
-name = "crosvm_wl"
-path = "src/wl.rs"
+name = "crosvm_ext_wl"
+path = "src/ext/wl_main.rs"
+
+[[bin]]
+name = "crosvm_guest_wl"
+path = "src/guest/wl.rs"
 
 [profile.release]
 panic = 'abort'
 overflow-checks = true
 
 [workspace]
-members = ["qcow_utils",
-
-# TEMP
-# "data_socket",
-
-]
+members = ["qcow_utils"]
 exclude = [
     "assertions",
     "async_core",
@@ -81,6 +80,7 @@ protos = { path = "protos", optional = true }
 rand_ish = { path = "rand_ish" }
 remain = "*"
 resources = { path = "resources" }
+serde = "*"
 sync = { path = "sync" }
 sys_util = "*"
 vhost = { path = "vhost" }