summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-01-03 15:21:04 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-01-05 14:28:44 -0800
commitd42e4931436c67cfbf5750c5bc27f029f4fe64ac (patch)
tree9b94f42d12d213c1b3d26497b0088caca62cb9ce /Cargo.toml
parenta13839564cde44efdb9b39c8c6c6235171326e77 (diff)
downloadcrosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar.gz
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar.bz2
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar.lz
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar.xz
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.tar.zst
crosvm-d42e4931436c67cfbf5750c5bc27f029f4fe64ac.zip
sys_util: add memfd seal support to SharedMemory
Getting and settings seals is useful to ensure the size of files
underlying memory mappings doesn't shrink, which can trigger a SIGBUS on
access to the truncated pages.

This also bumps the libc version to get MFD_ALLOW_SEALING.

TEST=cargo test
BUG=None
CQ-DEPEND=CL:850535

Change-Id: Ifbe1ec2c47d3d5c51b63472f545acc10d3c8eed2
Reviewed-on: https://chromium-review.googlesource.com/849488
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 74e272b..98c824c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,7 @@ io_jail = { path = "io_jail" }
 kvm = { path = "kvm" }
 sys_util = { path = "sys_util" }
 kernel_loader = { path = "kernel_loader" }
-libc = "=0.2.32"
+libc = "=0.2.34"
 byteorder = "=1.1.0"
 vm_control = { path = "vm_control" }
 data_model = { path = "data_model" }