summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2017-09-19 17:48:41 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-09-20 03:39:24 -0700
commitab839e293da62aaff07d04503538808719ce83d9 (patch)
tree4d482e510515c5decd5ee02cddd1ef359cf3c5e6 /Cargo.toml
parent42b3e8da55a5bcb6038728a2843a673aa5826c04 (diff)
downloadcrosvm-ab839e293da62aaff07d04503538808719ce83d9.tar
crosvm-ab839e293da62aaff07d04503538808719ce83d9.tar.gz
crosvm-ab839e293da62aaff07d04503538808719ce83d9.tar.bz2
crosvm-ab839e293da62aaff07d04503538808719ce83d9.tar.lz
crosvm-ab839e293da62aaff07d04503538808719ce83d9.tar.xz
crosvm-ab839e293da62aaff07d04503538808719ce83d9.tar.zst
crosvm-ab839e293da62aaff07d04503538808719ce83d9.zip
fix dependency versions and add Cargo.lock
To ensure dependencies don't accidentally get updated, their versions are
fixed using the equals constraint. The Cargo.lock file is also checked in
so that the registry won't need to be downloaded by cargo.

These changes are needed so that the crosvm ebuild will not need to
download anything outside of its list of source packages.

TEST=./build_test
BUG=None

Change-Id: Iae8472de77e3589a453685717b26fb1ceb44e257
Reviewed-on: https://chromium-review.googlesource.com/674092
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fe51f13..64cb4e2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,8 +12,8 @@ io_jail = { path = "io_jail" }
 kvm = { path = "kvm" }
 sys_util = { path = "sys_util" }
 kernel_loader = { path = "kernel_loader" }
-libc = "0.2.29"
-byteorder = "1"
+libc = "=0.2.29"
+byteorder = "=1.1.0"
 syscall_defines = { path = "syscall_defines" }
 net_sys = { path = "net_sys" }
 net_util = { path = "net_util" }