summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChirantan Ekbote <chirantan@chromium.org>2018-06-22 19:00:30 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-08-08 13:45:41 -0700
commita79073ad7d244b45bca5ba0c5ddf92b04827fc24 (patch)
treef1cea7b698de43de0718a7d9116ff66b496ebb5b /Cargo.toml
parentf226e28632d95c8b3c8d90fbaaef1eda8509fc74 (diff)
downloadcrosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar.gz
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar.bz2
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar.lz
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar.xz
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.tar.zst
crosvm-a79073ad7d244b45bca5ba0c5ddf92b04827fc24.zip
9s: Server binary for the 9p file system
Add the 9s crate, which provides an executable that can serve the 9p
file system protocol.  It initially only supports connections over vsock
but can easily be extended to support network and unix domain socket
based connections.

BUG=chromium:703939
TEST=Run the server, have maitred connect to it over vsock, mount the
     9p file system in the guest kernel, share it with the penguin
     container, and run `bonnie++ -r 256 -s 512`
CQ-DEPEND=CL:1121550, CL:1166446

Change-Id: Ia0c72bcf29188bba4c07b6c0a2dd5a83d02339b5
Signed-off-by: Chirantan Ekbote <chirantan@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/1112870
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c3a5c2e..edeb1bb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,7 @@ lto = true
 panic = 'abort'
 
 [workspace]
+members = ["9s"]
 
 [features]
 plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]