summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2017-10-06 15:30:34 -0700
committerchrome-bot <chrome-bot@chromium.org>2017-10-09 17:39:04 -0700
commit94bf1bf6b4a7791757937e2ffb2a81e797b82922 (patch)
tree386430a70c5fe176d8ae981aa1ca9b5bfc2d346f /Cargo.toml
parentd0c9adc642fc968cb347952eed1d7fd0d0a8e80e (diff)
downloadcrosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.gz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.bz2
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.lz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.xz
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.tar.zst
crosvm-94bf1bf6b4a7791757937e2ffb2a81e797b82922.zip
Move vm_control to a top-level crate
Break out vm_control to a crate that will be able to used by more
modules. Having vm_control usable from outside crosvm makes it possible
to move the devices out of crosvm in a later commit.

Change-Id: I1f060700ed49b5d77519d55efa2430490d521256
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/706558
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 64cb4e2..a9c3b76 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,7 @@ net_sys = { path = "net_sys" }
 net_util = { path = "net_util" }
 vhost = { path = "vhost" }
 virtio_sys = { path = "virtio_sys" }
+vm_control = { path = "vm_control" }
 data_model = { path = "data_model" }
 
 [target.'cfg(target_arch = "x86_64")'.dependencies]