summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSonny Rao <sonnyrao@chromium.org>2018-02-12 19:38:35 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-02-26 22:07:15 -0800
commit8836bb51a23163c8d8fb55fbd271f619010d7f00 (patch)
tree0c42623cf2757259a9bd4bcb77c40bafa3cf1987 /Cargo.toml
parent42d194de3f8211746c9d37f3ee4e35a4fffaac48 (diff)
downloadcrosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar.gz
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar.bz2
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar.lz
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar.xz
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.tar.zst
crosvm-8836bb51a23163c8d8fb55fbd271f619010d7f00.zip
crosvm: move device_manager to it's own crate
I will be refactoring this code to mostly live in the architecture
code, but for now it's simpler to move it out into it's own crate.

BUG=chromium:797868
TEST=./build_test passes on all architectures
TEST=crosvm runs on caroline

Change-Id: I85c12696fcd5cbef6a72a6dcbc484a443e0b0784
Signed-off-by: Sonny Rao <sonnyrao@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/933084
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d00c58a..c0d1a1e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 
 [dependencies]
 devices = { path = "devices" }
+device_manager = { path = "device_manager" }
 io_jail = { path = "io_jail" }
 kvm = { path = "kvm" }
 kvm_sys = { path = "kvm_sys" }