summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDylan Reid <dgreid@chromium.org>2017-12-13 09:09:40 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-01-19 23:29:52 -0800
commit76968703ad9f5c4edb4c533026ee35b6bd54a3d2 (patch)
treefb9e20a74397d184f794cc32362fc6e0075aa492 /Cargo.toml
parente56e045b18259399b424a0dd2cb8c53309478b71 (diff)
downloadcrosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar.gz
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar.bz2
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar.lz
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar.xz
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.tar.zst
crosvm-76968703ad9f5c4edb4c533026ee35b6bd54a3d2.zip
Add qcow support crate
QCOW2 files will be used to store the VM's data on ChromeOS. Add
support for basic reading and writing of qcow files.

CQ-DEPEND=CL:872451
BUG=none
TEST=qcow unit tests and use "qemu-image check" to verify generated qcow
files.

Change-Id: I4b9e77e58edca69f894ede19e79ebd2cd7b2623e
Signed-off-by: Dylan Reid <dgreid@chromium.org>
Reviewed-on: https://chromium-review.googlesource.com/862628
Reviewed-by: Stephen Barber <smbarber@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 98c824c..759f352 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,6 +19,7 @@ libc = "=0.2.34"
 byteorder = "=1.1.0"
 vm_control = { path = "vm_control" }
 data_model = { path = "data_model" }
+qcow = { path = "qcow" }
 
 [target.'cfg(target_arch = "x86_64")'.dependencies]
 x86_64 = { path = "x86_64" }