summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-04-25 17:49:56 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-05-08 04:57:58 -0700
commit6f6854312df5691763f3ee80be84fde16e82f6b8 (patch)
tree2d853cff0b8f3e5ad442a198af7c8840243b5435 /Cargo.toml
parente0823392f4dde29f3bde7f98d0bc481654843d27 (diff)
downloadcrosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar.gz
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar.bz2
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar.lz
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar.xz
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.tar.zst
crosvm-6f6854312df5691763f3ee80be84fde16e82f6b8.zip
gpu_buffer: create bindings to minigbm
These bindings are needed to allocate dmabufs that will be used for
accelerated rendering and zero-copy virtio-wayland support.

TEST=cargo test -p gpu_buffer
BUG=chromium:837073

Change-Id: I96d7bcdeaa1eda616a25fdcfedcbb734cd585ae7
Reviewed-on: https://chromium-review.googlesource.com/1029410
Commit-Ready: David Reveman <reveman@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1771719..b6db1eb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,6 +16,7 @@ plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 arch = { path = "arch" }
 devices = { path = "devices" }
 device_manager = { path = "device_manager" }
+gpu_buffer = { path = "gpu_buffer", optional = true }
 io_jail = { path = "io_jail" }
 kvm = { path = "kvm" }
 kvm_sys = { path = "kvm_sys" }