summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorZach Reizner <zachr@google.com>2018-11-14 17:20:44 -0800
committerchrome-bot <chrome-bot@chromium.org>2018-11-16 05:01:41 -0800
commit674504a3de8c076a4a4607399beb30dba13893b0 (patch)
treef05fab72544c17e41a923a1fab5ba4a98923607e /Cargo.toml
parent2fb61f77feb10a80b0d8efa3b16a650385a09e02 (diff)
downloadcrosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar.gz
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar.bz2
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar.lz
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar.xz
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.tar.zst
crosvm-674504a3de8c076a4a4607399beb30dba13893b0.zip
move qcow_utils to members from dependencies
The qcow_utils crate is not a dependency of crosvm and should not be
built in the same phase as crosvm. Doing so was harmless before the
recent rustc/cargo changes, which seem to be triggering some kind of
race condition. This change works around the bug.

CQ-DEPEND=CL:1336738
TEST=cargo test --release
BUG=chromium:900366

Change-Id: I01048128b20cf06580e809f6701688ab72e7756d
Reviewed-on: https://chromium-review.googlesource.com/1336737
Commit-Ready: Zach Reizner <zachr@chromium.org>
Tested-by: Zach Reizner <zachr@chromium.org>
Reviewed-by: Dylan Reid <dgreid@chromium.org>
Reviewed-by: Daniel Verkamp <dverkamp@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c419574..6019fe8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,7 +9,7 @@ panic = 'abort'
 overflow-checks = true
 
 [workspace]
-members = ["9s"]
+members = ["9s", "qcow_utils"]
 
 [features]
 plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
@@ -39,7 +39,6 @@ qcow = { path = "qcow" }
 plugin_proto = { path = "plugin_proto", optional = true }
 crosvm_plugin = { path = "crosvm_plugin", optional = true }
 protobuf = { version = "=1.4.3", optional = true }
-qcow_utils = { path = "qcow_utils" }
 resources = { path = "resources" }
 p9 = { path = "p9" }
 rand = "=0.3.20"