summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLepton Wu <lepton@chromium.org>2018-11-21 11:06:18 -0800
committerchrome-bot <chrome-bot@chromium.org>2019-03-14 20:53:53 -0700
commit608938818be555b51695972a78fc3bbe9c64c850 (patch)
tree557a028cc1fa98052b516a41751e6ca4f223bb0a /Cargo.toml
parent1bc4a06801a312e4fb770d323c35d34065a4d618 (diff)
downloadcrosvm-608938818be555b51695972a78fc3bbe9c64c850.tar
crosvm-608938818be555b51695972a78fc3bbe9c64c850.tar.gz
crosvm-608938818be555b51695972a78fc3bbe9c64c850.tar.bz2
crosvm-608938818be555b51695972a78fc3bbe9c64c850.tar.lz
crosvm-608938818be555b51695972a78fc3bbe9c64c850.tar.xz
crosvm-608938818be555b51695972a78fc3bbe9c64c850.tar.zst
crosvm-608938818be555b51695972a78fc3bbe9c64c850.zip
Start render node host service in crosvm
BUG=b:118408510
TEST=manual - build crosvm with/without crosvm-gpu-forward USE flag and run arcvm.

Change-Id: Ibb85d52dc679aa8524b29d86148ca28d82d8fe98
Reviewed-on: https://chromium-review.googlesource.com/1347330
Commit-Ready: Lepton Wu <lepton@chromium.org>
Tested-by: Lepton Wu <lepton@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: Lepton Wu <lepton@chromium.org>
Reviewed-by: Zach Reizner <zachr@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cc39e5b..253604d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,6 +27,7 @@ gpu = ["devices/gpu"]
 usb-emulation = ["usb_util"]
 sandboxed-libusb = ["usb_util/sandboxed-libusb"]
 tpm = ["devices/tpm"]
+gpu-forward = ["render_node_forward"]
 
 [dependencies]
 arch = { path = "arch" }
@@ -58,6 +59,7 @@ resources = { path = "resources" }
 p9 = { path = "p9" }
 sync = { path = "sync" }
 rand_ish = { path = "rand_ish" }
+render_node_forward = { path = "render_node_forward", optional = true }
 
 [target.'cfg(target_arch = "x86_64")'.dependencies]
 x86_64 = { path = "x86_64" }