summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJingkui Wang <jkwang@google.com>2018-11-02 00:27:48 -0700
committerchrome-bot <chrome-bot@chromium.org>2018-12-01 01:08:35 -0800
commit33e08312f272c863f062fffe53ea4a4ce94e6e26 (patch)
treec58171884a5b0e4d16dd9a4ee8633d75a461a281 /Cargo.toml
parent9ae286d008fd1c2a5b7f25f4184529fe6b5f169d (diff)
downloadcrosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar.gz
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar.bz2
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar.lz
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar.xz
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.tar.zst
crosvm-33e08312f272c863f062fffe53ea4a4ce94e6e26.zip
usb_util: Create libusb wrapper
This wrapper will be part of usb emulation backend.

BUG=chromium:831850
TEST=local build

Change-Id: I084b15201941e4c16c4e3ff9b967e55db09db567
Reviewed-on: https://chromium-review.googlesource.com/1124870
Commit-Ready: Jingkui Wang <jkwang@google.com>
Tested-by: Jingkui Wang <jkwang@google.com>
Reviewed-by: Jingkui Wang <jkwang@google.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d42a220..90f9dc5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,6 +16,7 @@ plugin = ["plugin_proto", "crosvm_plugin", "protobuf"]
 default-no-sandbox = []
 wl-dmabuf = ["devices/wl-dmabuf", "gpu_buffer", "resources/wl-dmabuf"]
 gpu = ["devices/gpu"]
+usb-emulation = ["usb_util"]
 
 [dependencies]
 arch = { path = "arch" }
@@ -27,6 +28,7 @@ kvm = { path = "kvm" }
 kvm_sys = { path = "kvm_sys" }
 msg_socket = { path = "msg_socket" }
 sys_util = { path = "sys_util" }
+usb_util = { path = "usb_util", optional = true }
 kernel_cmdline = { path = "kernel_cmdline" }
 kernel_loader = { path = "kernel_loader" }
 libc = "=0.2.44"