summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJingkui Wang <jkwang@google.com>2019-03-08 20:41:57 -0800
committerchrome-bot <chrome-bot@chromium.org>2019-03-17 21:33:08 -0700
commit100e6e48ad292406fb6f0a7eeb85465850bc28c7 (patch)
tree30f59fcb07b7cbee649a07390cd2397cfb65c463 /Cargo.toml
parentc324429b467d530fbeadef1fc9b527bb23ce1632 (diff)
downloadcrosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar.gz
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar.bz2
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar.lz
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar.xz
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.tar.zst
crosvm-100e6e48ad292406fb6f0a7eeb85465850bc28c7.zip
implement xhci and add it to pci bus
Implement xhci controller, setup seccomp filters and add xhci to pci
bus.

CQ-DEPEND=CL:1512761
BUG=chromium:831850
TEST=local build
Change-Id: I5c05452ece66e99d3a670e259e095fca616e835d
Reviewed-on: https://chromium-review.googlesource.com/1512762
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: Jingkui Wang <jkwang@google.com>
Reviewed-by: Jingkui Wang <jkwang@google.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 253604d..ed06b35 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,9 +25,9 @@ default-no-sandbox = []
 wl-dmabuf = ["devices/wl-dmabuf", "gpu_buffer", "resources/wl-dmabuf"]
 gpu = ["devices/gpu"]
 usb-emulation = ["usb_util"]
-sandboxed-libusb = ["usb_util/sandboxed-libusb"]
 tpm = ["devices/tpm"]
 gpu-forward = ["render_node_forward"]
+sandboxed-libusb = ["devices/sandboxed-libusb", "usb_util/sandboxed-libusb", "vm_control/sandboxed-libusb"]
 
 [dependencies]
 arch = { path = "arch" }