summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@chromium.org>2019-03-12 20:52:19 -0700
committerchrome-bot <chrome-bot@chromium.org>2019-04-08 22:30:28 -0700
commit0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493 (patch)
treea98cebbc32e299cb73b2718ec823e0f1546c56e8 /Cargo.toml
parenta7d4ea6dd0646c2ed3f066e91d3d8b2ca62b5bad (diff)
downloadcrosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar.gz
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar.bz2
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar.lz
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar.xz
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.tar.zst
crosvm-0159e5ada20d67402ad3fc49bf7f6ea9f9cbe493.zip
edition: Update crosvm crate to 2018 edition
Separated out of CL:1513058 to make it possible to land parts
individually while the affected crate has no other significant CLs
pending. This avoids repeatedly introducing non-textual conflicts with
new code that adds `use` statements.

TEST=cargo check
TEST=cargo check --all-features
TEST=cargo check --target aarch64-unknown-linux-gnu

Change-Id: If27a414db82bd6005d8067af24639f309d3b5e2e
Reviewed-on: https://chromium-review.googlesource.com/1519691
Commit-Ready: ChromeOS CL Exonerator Bot <chromiumos-cl-exonerator@appspot.gserviceaccount.com>
Tested-by: David Tolnay <dtolnay@chromium.org>
Tested-by: kokoro <noreply+kokoro@google.com>
Reviewed-by: David Tolnay <dtolnay@chromium.org>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 23fce21..7343025 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,6 +2,7 @@
 name = "crosvm"
 version = "0.1.0"
 authors = ["The Chromium OS Authors"]
+edition = "2018"
 
 [profile.release]
 panic = 'abort'